This topic has 11 replies, 3 voices, and was last updated 2 years, 2 months ago by admin.

  • Author
    Posts
  • #13354
     Grant Gordon
    Participant

    Is it possible for the device to recall the state of LEDs after preset switches? For example I’m now using it as a guitar pedalboard but when I switch away from that preset and come back all the LEDs are reset. It’d be nice if they ‘membered.
    Also an LED option for program changes would be useful.

    Thanks!

    • This topic was modified 2 years, 3 months ago by Grant Gordon.
    #13359
     admin
    Keymaster

    Yes! This is already a thing. All you should have to do is make sure that Track and Remote are turned on for the DataLooper Output port and your CC# messages should sync after changing presets. I am also using it as a pedal board and I made sure this feature worked because I need it to perform with 😉 I’ll add LED option for program changes to my list of things…how would that work though, since PC’s are momentary; just an option to select an LED color in the config software?

    #13361
     Grant Gordon
    Participant

    Well hot damn that’s exciting! Mine isn’t functioning like that at the moment however. I do have track and remote (and sync) set up in the Datalooper output. I switch to my guitar preset (preset 5). I hit the first switch which is a CC toggle set to CC1 on channel 2, the LED lights up, I switch back to preset 1, then back to 5 and that LED is not lit. I tried disconnecting my other controller (Akai MPK249) but still didn’t work. What else should I try? Thanks!

    #13362
     Grant Gordon
    Participant

    Oh and for the program change I see your point. It’s just in my functionality I use program changes to switch midi instrument patches, so it would be cool if I could have an LED that showed which I have selected. In this case it would light up on what you press, then when you press another, the previous LED turns off and the new one turns on, so it’s one at a time. Not sure if that’s a pain in the butt, but I can’t be the only one patch switchin out here, I sure hope not!

    #13363
     admin
    Keymaster

    This functionality is already implemented for Control Change messages (not the toggle sort), if you program the looper to use the same CC# but a different value, it will do this. I’ll keep that in mind for program changes though. The only thing tricky about that is that the looper is the only thing keeping track of what program you’re on, and doesn’t really know that the program changes are being routed to a single device in your setup, if that makes sense; so the LED functionality you want may be a hassle for someone who wants to use the PC messages in a different way (with multiple devices for example).

    #13364
     admin
    Keymaster

    Also, regarding the recall of the CCs for ‘stompbox’ memory. Make sure you have the DataLooper script selected in Control Surface, then select DataLooper for Input/Output. The script needs to be running as it sends a request to the Ableton system to spit out the value of mapped parameters when it sends a preset change. To check if this is working, you can use this program (https://www.snoize.com/MIDIMonitor/) and watch for output to the DataLooper when you initially open your session. If you don’t see your mapped parameter values being sent out, then there’s a configuration issue in the MIDI/sync prefs. If you do see the values being sent out on initial load, but not on presets, and have the script running and connected to the DL, something else is going on and I’d be happy to look in to it via a screen share.

    #13365
     Grant Gordon
    Participant

    Thanks for this info. I used midimonitor and saw mostly sysex msgs being sent to the datalooper and only 2 control messages which were for a mod wheel on channel 2. My settings are exactly as in the userguide, I’m running the script, input/output are on datalooper, and the track/sync/remote settings are as directed. Before we continue I should ask: is this a Live 10 only feature? Because I have Live 9.

    #13366
     Grant Gordon
    Participant

    Time out! I do see it. I changed my tester to CC 20 bc it’s an unassigned CC, and it’s value IS being sent to the DL but only on when I switch back to preset 1, not when I switch to preset 5 (my pedalboard).

    #13367
     Grant Gordon
    Participant

    I also tried flashing on the effects controller config, it just doesn’t seem to be pinging ableton for the CC statuses on preset changes. Midi monitor shows 4 resets from the DL and then this sysex:
    20:26:34.762 From DataLooper SysEx Key Concepts 6 bytes F0 1E 09 00 00 F7

    Then nothin.

    #13368
     admin
    Keymaster

    Hmm why don’t you give me a call and we can see what’s up. 805-242-6506.

    #13412
     Derek Muro
    Participant

    Having the LED color be configurable would be a great addition. I use a variety of clip launches, MIDI notes, CCs – would be fantastic to color code them.

    #13415
     admin
    Keymaster

    Will be adding in v 1.1. Coming soon…

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

CONTACT US

We're not around right now. But you can send us an email and we'll get back to you, asap.

Sending

©2021 DataLooper

or

Log in with your credentials

or    

Forgot your details?

or

Create Account