This topic has 6 replies, 4 voices, and was last updated 9 months, 1 week ago by Cly Lunt.

  • Author
    Posts
  • #13295
     TSA
    Participant

    I installed the remote script as instructed and Datalooper shows up as a control surface but there is no way to select it for input/output in my MIDI preferences. I am running a licensed copy of Ableton Live 10 Suite.

    #13297
     admin
    Keymaster

    Ok that means that the DataLooper is not being seen by the computer for some reason. Can you let me know the following?

    1. When you plugin in the DataLooper via USB (using the included cable without any hubs), does the LED on the bottom row, third column light up white?
    If the answer is no, then download TyTools (https://github.com/Koromix/tytools/releases) and run TyUpdater.
    When you run TyUpdater, let me know if you see DataLooper and then a string of numbers in the dropdown menu. If you do not, then there’s a USB connectivity issue and I can help you further diagnose.

    2. If you do see that LED turn on when you plug in the pedal, can you post your OS version here?

    • This reply was modified 2 years, 3 months ago by admin.
    #13349
     Michal
    Participant

    Hello, I have same problem here just with Ableton 10 Live lite updated and licensed, any suggestions?
    I m running on Mojave 10.14.3 and I just see 1 led white bottom 3rd from left up…
    and no options in input/output in my MIDI preferences…

    #13350
     admin
    Keymaster

    If the DataLooper is lighting up but not showing up in Input/Output, that indicates a USB communication issue. The fact that it’s lighting up means it’s getting power, but if it’s not showing up in Input/Output, that means that the computer is not seeing the device. To test the DataLooper, make sure that it’s plugged directly into the computer USB port with the cable that shipped with the DataLooper (some cables only transmit power, but not data). If the DataLooper still doesn’t show up, feel free to call me at 805-242-6506 and we can sort it out via a screen share.

    • This reply was modified 2 years, 3 months ago by admin.
    • This reply was modified 2 years, 3 months ago by admin.
    #13357
     admin
    Keymaster

    Hi guys. Michael and I just spoke and it turned out that the MicroUSB connector inside the unit had wiggled loose during shipping. Each DataLooper has a USB B female -> MicroUSB male cable inside the enclosure. This cable was added to provide an easy way to fix a unit in the event of someone damaging the USB B connection (beer, yanking crazy hard, etc..). If you can’t get the unit to show up on your computer; it’s worthwhile to open up the back of the DataLooper and unplug/replug that MicroUSB connector. Just for kicks, here’s a list of all the diagnostic steps that can be taken to revive an unresponsive DataLooper:

    1. Make sure you are using the cord that came with the DataLooper
    2. Make sure the cord is plugged directly into a USB port on the computer
    3. If the DataLooper does not show up in Input/Output, open up TyUpdater (https://github.com/Koromix/tytools/releases); if TyUpdater’s dropdown menu is empty, this means the DataLooper is not being seen at all by the computer.
      Unplug DataLooper, remove the screws from the back plate on the DataLooper and unplug/replug the microUSB connector cable.
      Replug-in DataLooper and test again. If it’s still not showing up, the last thing we can try is a hardware reset.
    4. With DataLooper plugged in and the back plate off, locate the two angled solder points labeled PGM1.
      Using a conductive piece of metal (a key or a screwdriver that doesn’t have a coating on it), bridge those two points for 5 seconds, then remove the piece of metal.
    5. Open up TyUpdater; a device name should show in the dropdown;
      If the device shows up as ‘DataLooper’, test in Ableton. If the device shows up in Ableton but is experiencing issues, reflash the firmware, using TyUpdater and the firmware @ https://www.datalooperpedal.com/resources
    6. If no device name shows up in TyUpdater, there’s one very last thing we can try.
      Download and install the Arduino IDE and Teensy IDE using this link. Follow the instructions in this link: https://www.pjrc.com/teensy/teensyduino.html
      Open up the Arduino IDE and go to Tools->Board and select Teensy LC, then go to Tools->Port. With DataLooper plugged in, you should see something that looks like “/dev/cu.usbmodemxxxx”. If you do not see this, try jumping that same connection point indicated in the image again and then checking in the Tools->Port area to see if that “/dev/cu.usbmodemxxxx” connection shows up. If you cannot get it to show up, there is most likely a short in the circuit board and it will need to be sent in for repair or replacement. If it does show up, close the Arduino IDE and reflash the default firmware using the TyUpdater tool.
    • This reply was modified 2 years, 3 months ago by admin.
    #13360
     Michal
    Participant

    Hi, YES I can confirm it was that silly, surly bumping, usb inside got disconnected just a touch and now DATA LOOPER is in full working order and feels so good it is solved. Thanks Vince for support and quick response helping this done in a minutes. Happy days!

    #16325
     Cly Lunt
    Participant

    Hello…In Controller Manager set the Out-Port for at any rate one consistent regulator to All Ports if this Traktor occasion is the MIDI clock Master. Or on the other hand set the In-Port for at any rate one intelligent regulator to All Ports if this Traktor example is the MIDI clock slave.
    Use Controller Manager to add another legitimate contoller. Try not to plan any orders into this sensible regulator. Set the Out-Port to the MIDI port on which Traktor will send the MIDI clock information if this Traktor example is the MIDI clock ace. Or on the other hand set the In-Port to the MIDI port in which Traktor will get the MIDI clock information if this Traktor occurrence is the MIDI clock slave.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

CONTACT US

We're not around right now. But you can send us an email and we'll get back to you, asap.

Sending

©2021 DataLooper

or

Log in with your credentials

or    

Forgot your details?

or

Create Account